package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<code>\+?\d{1,3})[-\s]{0,}(?<number>\(?\d{3}\)?[-\s]{0,}\d{3}[-\s]{0,}\d{2}[-\s]{0,}\d{2})$`)
var str = `+447700150563
+14247323156
+12048170348
+33644628265
+78005553535
88005553535
8-800-555-35-35
8 800 555 35 35
8(800)5553535
8-(800)5553535
8-(800) 555 3535
8 (800) 555 3535`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}