re = /^(?:[1-9]\d*?|0)?(?:\.(?:\d*?[1-9]|0))?(?<=[\d])$/m
str = '1.6
.16
16
0.6
01.6
0.
0
0.0
.0
.01
.001
1.60
100
100.0001
601.10
601.119201
1.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end