const regex = /^(?:[1-9]\d*?|0)?(?:\.(?:\d*?[1-9]|0))?(?<=[\d])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[1-9]\\d*?|0)?(?:\\.(?:\\d*?[1-9]|0))?(?<=[\\d])$', 'gm')
const str = `1.6
.16
16
0.6
01.6
0.
0
0.0
.0
.01
.001
1.60
100
100.0001
601.10
601.119201
1.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}