#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[1-9]\d*?|0)?(?:\.(?:\d*?[1-9]|0))?(?<=[\d])$"
Local $sString = "1.6" & @CRLF & _
".16" & @CRLF & _
"16" & @CRLF & _
"0.6" & @CRLF & _
"01.6" & @CRLF & _
"0." & @CRLF & _
"0" & @CRLF & _
"0.0" & @CRLF & _
".0" & @CRLF & _
".01" & @CRLF & _
".001" & @CRLF & _
"1.60" & @CRLF & _
"100" & @CRLF & _
"100.0001" & @CRLF & _
"601.10" & @CRLF & _
"601.119201" & @CRLF & _
"1.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")