import Foundation
let pattern = #"(?:\s*(?:\"([^\"]*)\"|([^;]+))\s*,?)+?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"IP";"IP_Phys_NET-LG-Facility";"Facility network at LG";"192.168.167.0/24";"IP_Phys_s7362";"IP_Zone_Network-Transit-Loopback";;
"Rule";"Mgmt_AdminVMs";"Added SV_RDP-UDP -- Mgmt access to any. Can be restricted to OS based rules for virtual destinations as soon as physical and virtual networks are segregated.";"SG_Mgmt_AdminVMs";"any";"SV_PING,SV_SSH,SV_PSRemoting,SVG_RDP";"DISTRIBUTED_FIREWALL";"Management_AdminVMs";"allow";"true";"false";"false";"inout";"false"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)