const regex = /(?:\s*(?:\"([^\"]*)\"|([^;]+))\s*,?)+?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*(?:\\"([^\\"]*)\\"|([^;]+))\\s*,?)+?', 'g')
const str = `"IP";"IP_Phys_NET-LG-Facility";"Facility network at LG";"192.168.167.0/24";"IP_Phys_s7362";"IP_Zone_Network-Transit-Loopback";;
"Rule";"Mgmt_AdminVMs";"Added SV_RDP-UDP -- Mgmt access to any. Can be restricted to OS based rules for virtual destinations as soon as physical and virtual networks are segregated.";"SG_Mgmt_AdminVMs";"any";"SV_PING,SV_SSH,SV_PSRemoting,SVG_RDP";"DISTRIBUTED_FIREWALL";"Management_AdminVMs";"allow";"true";"false";"false";"inout";"false"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}