# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s*(?:\"([^\"]*)\"|([^;]+))\s*,?)+?"
test_str = ("\"IP\";\"IP_Phys_NET-LG-Facility\";\"Facility network at LG\";\"192.168.167.0/24\";\"IP_Phys_s7362\";\"IP_Zone_Network-Transit-Loopback\";;\n"
"\"Rule\";\"Mgmt_AdminVMs\";\"Added SV_RDP-UDP -- Mgmt access to any. Can be restricted to OS based rules for virtual destinations as soon as physical and virtual networks are segregated.\";\"SG_Mgmt_AdminVMs\";\"any\";\"SV_PING,SV_SSH,SV_PSRemoting,SVG_RDP\";\"DISTRIBUTED_FIREWALL\";\"Management_AdminVMs\";\"allow\";\"true\";\"false\";\"false\";\"inout\";\"false\"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.