re = /(?=<[^<]*\s+title="([^"]*)")|<\s*a[^>]*>([^<]*)(?:[^\/]*[^a]*[^>]*)(?<=[>])([^<]*)/
str = '<p title="caca"></p>
<p> </p>
<b>
</b>
<B>title=" gdd "</B>
<i title="caca">dsfgjdgfs</i>
<i title=" boudin ">dsfgjdgfs</i>
<i> </i>
<i> </i>
<strong></strong>
<a>hello</a>
<i style="color: orange"></i>
<a href="#"> bizurot </a> !probleme
<o: class="ms-crap"></o>
<a href="#" title=" kameleo " > test </a> !probleme <a href="#"> cramoute </a> !probleme
<a href="#" title=" banane " > test <strong>hello</strong> asaidali </a><a href="#"> hdsfahsdgf </a> !probleme </br>
<p>Not empty</p>
<p>Not
empty</p>
<i>
</i>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end