re = /\/config\/(?'asset'\w+)\/sim_mgmt\/v1\/(?'rsc'profile|link){1}(\?_=\d+)?$/i
str = '/config/dts_test/sim_mgmt/v1/profile
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end