const regex = /\/config\/(?'asset'\w+)\/sim_mgmt\/v1\/(?'rsc'profile|link){1}(\?_=\d+)?$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/config\\\/(?\'asset\'\\w+)\\\/sim_mgmt\\\/v1\\\/(?\'rsc\'profile|link){1}(\\?_=\\d+)?$', 'i')
const str = `/config/dts_test/sim_mgmt/v1/profile
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}