$re = '/\/config\/(?\'asset\'\w+)\/sim_mgmt\/v1\/(?\'rsc\'profile|link){1}(\?_=\d+)?$/i';
$str = '/config/dts_test/sim_mgmt/v1/profile
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);