$re = '/^(0([2-468-9]\d{7}|[5|7]\d{8}))$/';
$str = '0509165456';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);