package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0([2-468-9]\d{7}|[5|7]\d{8}))$`)
var str = `0509165456`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}