const regex = /^(0([2-468-9]\d{7}|[5|7]\d{8}))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0([2-468-9]\\d{7}|[5|7]\\d{8}))$', '')
const str = `0509165456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}