import Foundation
let pattern = #"[a-zA-Z0-9\/\–\?\:\(\)\.\,\‘\+\s]{0,140}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}