const regex = /[a-zA-Z0-9\/\–\?\:\(\)\.\,\‘\+\s]{0,140}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z0-9\\\/\\–\\?\\:\\(\\)\\.\\,\\‘\\+\\s]{0,140}', '')
const str = `Hallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}