re = /[a-zA-Z0-9\/\–\?\:\(\)\.\,\‘\+\s]{0,140}/
str = 'Hallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und ich bin 140 Zeichen langHallo mein Name ist Teresa und'
# Print the match result
str.match(re) do |match|
puts match.to_s
end