import Foundation
let pattern = #"<table.*?>(([\s*].*(\s*))+)?<\/table>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<table width="100%" cellspacing="0" cellpadding="4"><colgroup> <col width="85*" /> <col width="85*" /> <col width="85*" /> </colgroup>
<thead>
<tr valign="TOP">
<th width="33%">Th1</th>
<th width="33%">Th2</th>
<th width="33%">Th3</th>
</tr>
</thead>
<tbody>
<tr valign="TOP">
<td width="33%">C1</td>
<td width="33%">C2</td>
<td width="33%">C3</td>
</tr>
<tr valign="TOP">
<td width="33%">C4</td>
<td width="33%">C5</td>
<td width="33%">C6</td>
</tr>
<tr valign="TOP">
<td width="33%">C7</td>
<td width="33%">C8</td>
<td width="33%">C9</td>
</tr>
</tbody>
</table>
<h2>Title</h2>
<table width="100%" cellspacing="0" cellpadding="4"><colgroup> <col width="85*" /> <col width="85*" /> <col width="85*" /> </colgroup>
<thead>
<tr valign="TOP">
<th width="33%">Th1</th>
<th width="33%">Th2</th>
<th width="33%">Th3</th>
</tr>
</thead>
<tbody>
<tr valign="TOP">
<td width="33%">C1</td>
<td width="33%">C2</td>
<td width="33%">C3</td>
</tr>
<tr valign="TOP">
<td width="33%">C4</td>
<td width="33%">C5</td>
<td width="33%">C6</td>
</tr>
<tr valign="TOP">
<td width="33%">C7</td>
<td width="33%">C8</td>
<td width="33%">C9</td>
</tr>
</tbody>
</table>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}