import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<table.*?>(([\\s*].*(\\s*))+)?<\\/table>";
final String string = "<table width=\"100%\" cellspacing=\"0\" cellpadding=\"4\"><colgroup> <col width=\"85*\" /> <col width=\"85*\" /> <col width=\"85*\" /> </colgroup>\n"
+ "<thead>\n"
+ "<tr valign=\"TOP\">\n"
+ "<th width=\"33%\">Th1</th>\n"
+ "<th width=\"33%\">Th2</th>\n"
+ "<th width=\"33%\">Th3</th>\n"
+ "</tr>\n"
+ "</thead>\n"
+ "<tbody>\n"
+ "<tr valign=\"TOP\">\n"
+ "<td width=\"33%\">C1</td>\n"
+ "<td width=\"33%\">C2</td>\n"
+ "<td width=\"33%\">C3</td>\n"
+ "</tr>\n"
+ "<tr valign=\"TOP\">\n"
+ "<td width=\"33%\">C4</td>\n"
+ "<td width=\"33%\">C5</td>\n"
+ "<td width=\"33%\">C6</td>\n"
+ "</tr>\n"
+ "<tr valign=\"TOP\">\n"
+ "<td width=\"33%\">C7</td>\n"
+ "<td width=\"33%\">C8</td>\n"
+ "<td width=\"33%\">C9</td>\n"
+ "</tr>\n"
+ "</tbody>\n"
+ "</table>\n\n"
+ "<h2>Title</h2>\n"
+ "<table width=\"100%\" cellspacing=\"0\" cellpadding=\"4\"><colgroup> <col width=\"85*\" /> <col width=\"85*\" /> <col width=\"85*\" /> </colgroup>\n"
+ "<thead>\n"
+ "<tr valign=\"TOP\">\n"
+ "<th width=\"33%\">Th1</th>\n"
+ "<th width=\"33%\">Th2</th>\n"
+ "<th width=\"33%\">Th3</th>\n"
+ "</tr>\n"
+ "</thead>\n"
+ "<tbody>\n"
+ "<tr valign=\"TOP\">\n"
+ "<td width=\"33%\">C1</td>\n"
+ "<td width=\"33%\">C2</td>\n"
+ "<td width=\"33%\">C3</td>\n"
+ "</tr>\n"
+ "<tr valign=\"TOP\">\n"
+ "<td width=\"33%\">C4</td>\n"
+ "<td width=\"33%\">C5</td>\n"
+ "<td width=\"33%\">C6</td>\n"
+ "</tr>\n"
+ "<tr valign=\"TOP\">\n"
+ "<td width=\"33%\">C7</td>\n"
+ "<td width=\"33%\">C8</td>\n"
+ "<td width=\"33%\">C9</td>\n"
+ "</tr>\n"
+ "</tbody>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}