// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<table.*?>(([\s*].*(\s*))+)?<\/table>").unwrap();
let string = "<table width=\"100%\" cellspacing=\"0\" cellpadding=\"4\"><colgroup> <col width=\"85*\" /> <col width=\"85*\" /> <col width=\"85*\" /> </colgroup>
<thead>
<tr valign=\"TOP\">
<th width=\"33%\">Th1</th>
<th width=\"33%\">Th2</th>
<th width=\"33%\">Th3</th>
</tr>
</thead>
<tbody>
<tr valign=\"TOP\">
<td width=\"33%\">C1</td>
<td width=\"33%\">C2</td>
<td width=\"33%\">C3</td>
</tr>
<tr valign=\"TOP\">
<td width=\"33%\">C4</td>
<td width=\"33%\">C5</td>
<td width=\"33%\">C6</td>
</tr>
<tr valign=\"TOP\">
<td width=\"33%\">C7</td>
<td width=\"33%\">C8</td>
<td width=\"33%\">C9</td>
</tr>
</tbody>
</table>
<h2>Title</h2>
<table width=\"100%\" cellspacing=\"0\" cellpadding=\"4\"><colgroup> <col width=\"85*\" /> <col width=\"85*\" /> <col width=\"85*\" /> </colgroup>
<thead>
<tr valign=\"TOP\">
<th width=\"33%\">Th1</th>
<th width=\"33%\">Th2</th>
<th width=\"33%\">Th3</th>
</tr>
</thead>
<tbody>
<tr valign=\"TOP\">
<td width=\"33%\">C1</td>
<td width=\"33%\">C2</td>
<td width=\"33%\">C3</td>
</tr>
<tr valign=\"TOP\">
<td width=\"33%\">C4</td>
<td width=\"33%\">C5</td>
<td width=\"33%\">C6</td>
</tr>
<tr valign=\"TOP\">
<td width=\"33%\">C7</td>
<td width=\"33%\">C8</td>
<td width=\"33%\">C9</td>
</tr>
</tbody>
</table>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}