import Foundation
let pattern = #".*((de)|(dk)|(no)|(jp))_2015.+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
2
viatormobileprd_2015-12-05.tar.gz
3
viatorpartnerprd_2015-12-05.tar.gz
viatormpartnerprd_2015-12-05.tar.gz
viatorcomse_2015-12-05.tar.gz
viatormse_2015-12-05.tar.gz
4
viatorcomfr_2015-12-05.tar.gz
viatormfr_2015-12-05.tar.gz
viatorcomit_2015-12-05.tar.gz
viatormit_2015-12-05.tar.gz
viatorcomnl_2015-12-05.tar.gz
viatormnl_2015-12-05.tar.gz
5
viatorcomes_2015-12-05.tar.gz
viatormes_2015-12-05.tar.gz
viatorcombr_2015-12-05.tar.gz
viatormbr_2015-12-05.tar.gz
6
viatorcomde_2015-12-05.tar.gz
viatormde_2015-12-05.tar.gz
viatorcomdk_2015-12-05.tar.gz
viatorcomno_2015-12-05.tar.gz
viatorcomjp_2015-12-05.tar.gz
viatormjp_2015-12-05.tar.gz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)