use strict;
my $str = '2
viatormobileprd_2015-12-05.tar.gz
3
viatorpartnerprd_2015-12-05.tar.gz
viatormpartnerprd_2015-12-05.tar.gz
viatorcomse_2015-12-05.tar.gz
viatormse_2015-12-05.tar.gz
4
viatorcomfr_2015-12-05.tar.gz
viatormfr_2015-12-05.tar.gz
viatorcomit_2015-12-05.tar.gz
viatormit_2015-12-05.tar.gz
viatorcomnl_2015-12-05.tar.gz
viatormnl_2015-12-05.tar.gz
5
viatorcomes_2015-12-05.tar.gz
viatormes_2015-12-05.tar.gz
viatorcombr_2015-12-05.tar.gz
viatormbr_2015-12-05.tar.gz
6
viatorcomde_2015-12-05.tar.gz
viatormde_2015-12-05.tar.gz
viatorcomdk_2015-12-05.tar.gz
viatorcomno_2015-12-05.tar.gz
viatorcomjp_2015-12-05.tar.gz
viatormjp_2015-12-05.tar.gz
';
my $regex = qr/.*((de)|(dk)|(no)|(jp))_2015.+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}