import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*((de)|(dk)|(no)|(jp))_2015.+";
final String string = "2\n\n"
+ "viatormobileprd_2015-12-05.tar.gz\n\n"
+ "3\n"
+ "viatorpartnerprd_2015-12-05.tar.gz\n"
+ "viatormpartnerprd_2015-12-05.tar.gz\n"
+ "viatorcomse_2015-12-05.tar.gz\n"
+ "viatormse_2015-12-05.tar.gz\n\n\n"
+ "4\n"
+ "viatorcomfr_2015-12-05.tar.gz\n"
+ "viatormfr_2015-12-05.tar.gz\n"
+ "viatorcomit_2015-12-05.tar.gz\n"
+ "viatormit_2015-12-05.tar.gz\n"
+ "viatorcomnl_2015-12-05.tar.gz\n"
+ "viatormnl_2015-12-05.tar.gz\n\n"
+ "5\n"
+ "viatorcomes_2015-12-05.tar.gz\n"
+ "viatormes_2015-12-05.tar.gz\n"
+ "viatorcombr_2015-12-05.tar.gz\n"
+ "viatormbr_2015-12-05.tar.gz\n\n"
+ "6\n"
+ "viatorcomde_2015-12-05.tar.gz\n"
+ "viatormde_2015-12-05.tar.gz\n"
+ "viatorcomdk_2015-12-05.tar.gz\n"
+ "viatorcomno_2015-12-05.tar.gz\n"
+ "viatorcomjp_2015-12-05.tar.gz\n"
+ "viatormjp_2015-12-05.tar.gz\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}