re = /^(?:(?<!\/\/|\/\*|<!--).)* #check if commented out
<[a-z][a-z0-9]*?\b #find start of a tag
(?:.(?![^?]>))+ #Must not find > between start and class unless ?>
class=(["']) #Find class and opening quotes
(?:(?!\1).)* \bmatch\b (?:(?!\1).)* #see if our tag is in between the quotes
\1 #closing quotes
.*(?<!\?)> #find first > without ? in front of it/mix
str = '<h1 class="match">Match list</h1>
<p class="match">Simple class element.</p>
<p></p> <h6 class=\'more match classes\'> more classes different comma</h6>
<fdf <?php echo \'data="extra data test to disturb the page."\'; ?> class=\'incluEdit match classes\' > dffd
<div class=\'hoppa match more classes\' <?=$zooi ?> > nested elements </div></div>
// <h1 class=\'match more classes\'> no Match list</h1>
/* <h1 class=\'match more classes\'> no Match list</h1>
<!-- <h1 class=\'match more classes\'> no Match list</h1>
<p class=\'nomatch more classes\'>shouldn\'t match</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end