import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?<!\\/\\/|\\/\\*|<!--).)* #check if commented out\n"
+ "<[a-z][a-z0-9]*?\\b #find start of a tag\n"
+ "(?:.(?![^?]>))+ #Must not find > between start and class unless ?>\n"
+ "class=([\"']) #Find class and opening quotes\n"
+ "(?:(?!\\1).)* \\bmatch\\b (?:(?!\\1).)* #see if our tag is in between the quotes\n"
+ "\\1 #closing quotes\n"
+ ".*(?<!\\?)> #find first > without ? in front of it";
final String string = "<h1 class=\"match\">Match list</h1>\n\n"
+ "<p class=\"match\">Simple class element.</p>\n\n"
+ " <p></p> <h6 class='more match classes'> more classes different comma</h6>\n\n"
+ " <fdf <?php echo 'data=\"extra data test to disturb the page.\"'; ?> class='incluEdit match classes' > dffd\n\n"
+ " <div class='hoppa match more classes' <?=$zooi ?> > nested elements </div></div>\n\n"
+ "// <h1 class='match more classes'> no Match list</h1>\n"
+ "/* <h1 class='match more classes'> no Match list</h1>\n"
+ "<!-- <h1 class='match more classes'> no Match list</h1>\n\n\n"
+ "<p class='nomatch more classes'>shouldn't match</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}