# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(?:(?<!\/\/|\/\*|<!--).)* #check if commented out
<[a-z][a-z0-9]*?\b #find start of a tag
(?:.(?![^?]>))+ #Must not find > between start and class unless ?>
class=(["']) #Find class and opening quotes
(?:(?!\1).)* \bmatch\b (?:(?!\1).)* #see if our tag is in between the quotes
\1 #closing quotes
.*(?<!\?)> #find first > without ? in front of it
"""
test_str = ("<h1 class=\"match\">Match list</h1>\n\n"
"<p class=\"match\">Simple class element.</p>\n\n"
" <p></p> <h6 class='more match classes'> more classes different comma</h6>\n\n"
" <fdf <?php echo 'data=\"extra data test to disturb the page.\"'; ?> class='incluEdit match classes' > dffd\n\n"
" <div class='hoppa match more classes' <?=$zooi ?> > nested elements </div></div>\n\n"
"// <h1 class='match more classes'> no Match list</h1>\n"
"/* <h1 class='match more classes'> no Match list</h1>\n"
"<!-- <h1 class='match more classes'> no Match list</h1>\n\n\n"
"<p class='nomatch more classes'>shouldn't match</p>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.