re = /"(.*?)/m
str = '"Ganymede," he continued, "is the largest moon in the Solar System."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end