package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(.*?)`)
var str = `"Ganymede," he continued, "is the largest moon in the Solar System."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}