import Foundation
let pattern = #"^(BEJ|KIM)-([0-9]{8})\/([0-9]{3})\/([0-9]{4})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"BEJ-12345678/001/2014"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}