package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(BEJ|KIM)-([0-9]{8})\/([0-9]{3})\/([0-9]{4})$`)
var str = `BEJ-12345678/001/2014`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}