using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(BEJ|KIM)-([0-9]{8})\/([0-9]{3})\/([0-9]{4})$";
string input = @"BEJ-12345678/001/2014";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}