// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:(?:http(?:s?)://)?(?:www\.)?vk\.com/video)(?:\?z=video)?(-?\d{5,}_\d{5,})").unwrap();
let string = "https://vk.com/video-23213239_171659525";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}