re = /^(?:(?:http(?:s?):\/\/)?(?:www\.)?vk\.com\/video)(?:\?z=video)?(-?\d{5,}_\d{5,})/
str = 'https://vk.com/video-23213239_171659525'
# Print the match result
str.match(re) do |match|
puts match.to_s
end