$re = '@^(?:(?:http(?:s?)://)?(?:www\.)?vk\.com/video)(?:\?z=video)?(-?\d{5,}_\d{5,})@';
$str = 'https://vk.com/video-23213239_171659525';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);