re = /[:=\)][ -]?\)+|ddd+|\+\+\++|xdd+|:d+/m
str = ':) =) )) : ) :-) ddddd +++ xddd :ddd xd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end