$re = '/[:=\)][ -]?\)+|ddd+|\+\+\++|xdd+|:d+/m';
$str = ':) =) )) : ) :-) ddddd +++ xddd :ddd xd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);