package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[:=\)][ -]?\)+|ddd+|\+\+\++|xdd+|:d+`)
var str = `:) =) )) : ) :-) ddddd +++ xddd :ddd xd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}