import Foundation
let pattern = #"(\'|"")My-Text(\'|""):.*?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{''Remote-Control': 'no-control, must', 'My-Text': "input-src 'something' 'perfect-out' 'perfect-in' *.exampl.com", 'Some': '1; 'Encoding': 'gzip'}
{''Remote-Control': 'no-control, must', 'My-Text': "input-src *", 'Some': '1; 'Encoding': 'gzip'}
{''Remote-Control': 'no-control, must', 'My-Text': "output-src *.exampl.com", 'Some': '1; 'Encoding': 'gzip'}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)