// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\'|"")My-Text(\'|""):.*?"#).unwrap();
let string = "{''Remote-Control': 'no-control, must', 'My-Text': \"input-src 'something' 'perfect-out' 'perfect-in' *.exampl.com\", 'Some': '1; 'Encoding': 'gzip'}
{''Remote-Control': 'no-control, must', 'My-Text': \"input-src *\", 'Some': '1; 'Encoding': 'gzip'}
{''Remote-Control': 'no-control, must', 'My-Text': \"output-src *.exampl.com\", 'Some': '1; 'Encoding': 'gzip'}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}