const regex = new RegExp('(\\\\'|"")My-Text(\\\\'|""):.*?', 'gm')
const str = `{''Remote-Control': 'no-control, must', 'My-Text': "input-src 'something' 'perfect-out' 'perfect-in' *.exampl.com", 'Some': '1; 'Encoding': 'gzip'}
{''Remote-Control': 'no-control, must', 'My-Text': "input-src *", 'Some': '1; 'Encoding': 'gzip'}
{''Remote-Control': 'no-control, must', 'My-Text': "output-src *.exampl.com", 'Some': '1; 'Encoding': 'gzip'}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}