re = /\[[{,%]?(?<fieldName>.+)(\((?<fieldId>\d+)\))?[},%]?\]/mx
str = '[FieldName(5454)]
[{FieldName}]
[{FieldName(5454)}]
[%FieldName(5454)%]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end