using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[{,%]?(?<fieldName>.+)(\((?<fieldId>\d+)\))?[},%]?\]";
string input = @"[FieldName(5454)]
[{FieldName}]
[{FieldName(5454)}]
[%FieldName(5454)%]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}