$re = '/\[[{,%]?(?<fieldName>.+)(\((?<fieldId>\d+)\))?[},%]?\]/mx';
$str = '[FieldName(5454)]
[{FieldName}]
[{FieldName(5454)}]
[%FieldName(5454)%]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);