$re = '/datafile[0-9]*.txt/';
$str = 'datafile2.txt
datafile.txt
datafile1_6.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);