package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`datafile[0-9]*.txt`)
var str = `datafile2.txt
datafile.txt
datafile1_6.txt
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}