using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"datafile[0-9]*.txt";
string input = @"datafile2.txt
datafile.txt
datafile1_6.txt
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}