# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\<!--\s\w\:[\d\w]*\:\s--\>)"
test_str = ("Привет, \n\n"
"в этом видео я расскажу, как подвесить картинку на форум с помощью фотохостинга (сервиса хранения картинок).\n"
"Мы будем использовать сервис Itmages: [url:3flgucgy]https://itmages.ru[/url:3flgucgy]\n\n"
"[media:3flgucgy]https://www.youtube.com/embed/jhsjjSZjSco[/media:3flgucgy]\n\n"
"А вот результат:\n\n"
"Ой, прошу пардону! <!-- s:oops: --><img src=\"{SMILIES_PATH}/svf60a.gif\" alt=\":oops:\" title=\"Embarrassed\" /><!-- s:oops: --> Я- ворона!))) Вижу! Пасиб, Леш! <!-- s:flowers: --><img src=\"{SMILIES_PATH}/svf05cv.gif\" alt=\":flowers:\" title=\"Flowers\" /><!-- s:flowers: -->\n"
"[quote="Блик":15zse657]:ugeek:[/quote:15zse657]\n"
"Функция media работает также как и [mg\n"
"Копируете ссылку на видеохостинге YouTube и вставляете между квадратными скобками. Ссылку на ролик берёте не в строке браузера, а прямую - нажимаете на стрелочку , находящуюся справа внизу от видео, откроется окошко прямой ссылки ее и копируете, затем вставляете здесь.\n"
"Фото ирисов\n\n"
"[url=https://itmages.ru/image/view/5378517/7b0c21fd:3flgucgy][img:3flgucgy]http://storage4.static.itmages.ru/i/17/0116/s_1484583205_1067040_7b0c21fdd2.jpg[/img:3flgucgy][/url:3flgucgy]\n\n"
"[quote="АнаБолик":25vyhwt9]Леш, а нельзя как- то правильно поставить фотографии?)[/quote:25vyhwt9]\n\n"
"[img:25vyhwt9]http://cs5-3.4pda.to/986240.gif[/img:25vyhwt9]")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.