use strict;
my $str = 'Привет,
в этом видео я расскажу, как подвесить картинку на форум с помощью фотохостинга (сервиса хранения картинок).
Мы будем использовать сервис Itmages: [url:3flgucgy]https://itmages.ru[/url:3flgucgy]
[media:3flgucgy]https://www.youtube.com/embed/jhsjjSZjSco[/media:3flgucgy]
А вот результат:
Ой, прошу пардону! <!-- s:oops: --><img src="{SMILIES_PATH}/svf60a.gif" alt=":oops:" title="Embarrassed" /><!-- s:oops: --> Я- ворона!))) Вижу! Пасиб, Леш! <!-- s:flowers: --><img src="{SMILIES_PATH}/svf05cv.gif" alt=":flowers:" title="Flowers" /><!-- s:flowers: -->
[quote="Блик":15zse657]:ugeek:[/quote:15zse657]
Функция media работает также как и [mg
Копируете ссылку на видеохостинге YouTube и вставляете между квадратными скобками. Ссылку на ролик берёте не в строке браузера, а прямую - нажимаете на стрелочку , находящуюся справа внизу от видео, откроется окошко прямой ссылки ее и копируете, затем вставляете здесь.
Фото ирисов
[url=https://itmages.ru/image/view/5378517/7b0c21fd:3flgucgy][img:3flgucgy]http://storage4.static.itmages.ru/i/17/0116/s_1484583205_1067040_7b0c21fdd2.jpg[/img:3flgucgy][/url:3flgucgy]
[quote="АнаБолик":25vyhwt9]Леш, а нельзя как- то правильно поставить фотографии?)[/quote:25vyhwt9]
[img:25vyhwt9]http://cs5-3.4pda.to/986240.gif[/img:25vyhwt9]';
my $regex = qr/(\<!--\s\w\:[\d\w]*\:\s--\>)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";