#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\<!--\s\w\:[\d\w]*\:\s--\>)"
Local $sString = "Привет, " & @CRLF & _
"" & @CRLF & _
"в этом видео я расскажу, как подвесить картинку на форум с помощью фотохостинга (сервиса хранения картинок)." & @CRLF & _
"Мы будем использовать сервис Itmages: [url:3flgucgy]https://itmages.ru[/url:3flgucgy]" & @CRLF & _
"" & @CRLF & _
"[media:3flgucgy]https://www.youtube.com/embed/jhsjjSZjSco[/media:3flgucgy]" & @CRLF & _
"" & @CRLF & _
"А вот результат:" & @CRLF & _
"" & @CRLF & _
"Ой, прошу пардону! <!-- s:oops: --><img src="{SMILIES_PATH}/svf60a.gif" alt=":oops:" title="Embarrassed" /><!-- s:oops: --> Я- ворона!))) Вижу! Пасиб, Леш! <!-- s:flowers: --><img src="{SMILIES_PATH}/svf05cv.gif" alt=":flowers:" title="Flowers" /><!-- s:flowers: -->" & @CRLF & _
"[quote="Блик":15zse657]:ugeek:[/quote:15zse657]" & @CRLF & _
"Функция media работает также как и [mg" & @CRLF & _
"Копируете ссылку на видеохостинге YouTube и вставляете между квадратными скобками. Ссылку на ролик берёте не в строке браузера, а прямую - нажимаете на стрелочку , находящуюся справа внизу от видео, откроется окошко прямой ссылки ее и копируете, затем вставляете здесь." & @CRLF & _
"Фото ирисов" & @CRLF & _
"" & @CRLF & _
"[url=https://itmages.ru/image/view/5378517/7b0c21fd:3flgucgy][img:3flgucgy]http://storage4.static.itmages.ru/i/17/0116/s_1484583205_1067040_7b0c21fdd2.jpg[/img:3flgucgy][/url:3flgucgy]" & @CRLF & _
"" & @CRLF & _
"[quote="АнаБолик":25vyhwt9]Леш, а нельзя как- то правильно поставить фотографии?)[/quote:25vyhwt9]" & @CRLF & _
"" & @CRLF & _
"[img:25vyhwt9]http://cs5-3.4pda.to/986240.gif[/img:25vyhwt9]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)