re = /\b(r(a|à|á|â|ä|æ|ã|å|ā)p(e|3|è|é|ê|ë|ē|ė|ę))\s*/im
str = 'rape grape g rape ra pe rapes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end